标签 composer 下的文章

composer库相关笔记

每一个项目都是一个包.

名字是:厂商名/包名. 例如: laravel/laravel

包有版本,引入的时候不加就默认.否则就要写版本号.

包引入 用require. composer require nette/mial
限定版本 composer require nette/mial:2.2.5
也可以在composer.json里require上增加需要的包名与版本. 用 composer update引入

版本约束可以用几个不同的方法来指定。

名称 实例 描述
确切的版本号 1.0.2 你可以指定包的确切版本。
范围 >=1.0  >=1.0,<2.0 >=1.0,<1.1|>;=1.2 通过使用比较操作符可以指定有效的版本范围。
有效的运算符: >>=<<=!=
你可以定义多个范围,用逗号隔开,这将被视为一个逻辑AND处理。一个管道符号 |将作为逻辑OR处理。
AND 的优先级高于 OR。
通配符 1.0.* 你可以使用通配符 *来指定一种模式。 1.0.*>=1.0,>1.1是等效的。
赋值运算符 ~1.2 这对于遵循语义化版本号的项目非常有用。 ~1.2相当于 >=1.2,<2.0。想要了解更多,请阅读下一小节。

下一个重要版本(波浪号运算符)

~ 最好用例子来解释:  ~1.2 相当于  >=1.2,<2.0,而  ~1.2.3 相当于  >=1.2.3,<1.3。正如你所看到的这对于遵循 语义化版本号 的项目最有用。一个常见的用法是标记你所依赖的最低版本,像  ~1.2 (允许1.2以上的任何版本,但不包括2.0)。由于理论上直到2.0应该都没有向后兼容性问题,所以效果很好。你还会看到它的另一种用法,使用  ~ 指定最低版本,但允许版本号的最后一位数字上升。

注意: 虽然  2.0-beta.1 严格地说是早于  2.0,但是,根据版本约束条件, 例如  ~1.2 却不会安装这个版本。就像前面所讲的  ~1.2 只意味着  .2 部分可以改变,但是  1. 部分是固定的。

laravel5composer安装

装完composer之后,就打算来一下laravel5框架了.

composer 命令: composer create-project laravel/laravel=5.2.* demoname –prefer-dist

demoname 项目名称 laravel=5.2.* 是下载laravel5.2的版本  5.1就是 laravel=5.1.* 或者直接写版本号5.1.11, dist是优先安装压缩版.

后面这些参数都可以省略的.更具你的要求作出自己的参数.

之后等待走完进度.

访问出现laravel界面.证明安装成功.注意目录项目跟下有个server.php 与访问/public/index.php 效果相同.

linux下配置下文件权限:

chmod o+rwx <project>/storage -R
chmod o+rwx <project>/bootstrap/cache -R

.env是配置文件,修改相关配置.

config下也有相关配置.

composer安装

什么是composer?

我自己还真不会描述.来看人家自己介绍.

Composer 是 PHP 的一个依赖管理工具。

Composer 不是一个包管理器。是的,它涉及 “packages” 和 “libraries”,但它在每个项目的基础上进行管理,在你项目的某个目录中(例如  vendor)进行安装。默认情况下它不会在全局安装任何东西。因此,这仅仅是一个依赖管理。

好,就已经说明他是干嘛的了.

那他能干嘛?

Composer 将这样为你解决问题:

a) 你有一个项目依赖于若干个库。

b) 其中一些库依赖于其他库。

c) 你声明你所依赖的东西。

d) Composer 会找出哪个版本的包需要安装,并安装它们(将它们下载到你的项目中)。

系统要求:需要 PHP 5.3.2+ 以上版本。

那我们来装一个吧!

地址

windows   直接下载 Composer-Setup.exe.下一步下一步嘛.

linux (全局):

执行完打一下 composer 出现信息就ok了.

 

人生的悲剧只有两种:一种是没有得到自己想要的东西,另一种是得到自己想要的东西。
                                —王尔德

标签

打赏